Picking up new columns

Jun 25, 2009 at 5:00 AM

Hi I am learning how to use the component, and I found when I added a new column to my dimension, I couldn't pick it up without deleting the link to the table and then re-creating it.  The problem with this is, I then need to re-map the columns.

 

Am I missing something, or is this a limitation of the component ?

 

Thanks,

Leigh.

 

Jun 29, 2009 at 10:02 PM
Edited Jun 29, 2009 at 10:03 PM

I'm not sure I understand your scenario.  Is this what's happening:

Your table in SQL Server (or whatever DBMS) gets a new column added (a new "attribute"), and/or you edit the "source" component in SSIS to pick up a new column from your Existing Dimension table.  If you don't delete the connector from your "source" component to the KSCD component, then the KSCD component doesn't show your new column?

That can't be it - because when I attempt that, the KSCD immediately reports itself as "broken" (with a validation error) informing you that upstream column metadata has changed, and begs you to edit it.  Does this not happen to you?  If not, please describe in more detail what your package looks like, and what steps you take to "add a column".

Thanks for your post!

Jun 29, 2009 at 11:28 PM

Yes, That's whats happening.  

 

I gave up and went back to the standard SCD, but had problems with that anyway.  I have since installed SP3 and the standard SCD now works properly, so I will recreate it and see if the problem re-occurs.  I had other problems after this, so I will post a more comprehensive post with examples.